Prod-EU outage due to mongo cluster un-availability

Incident Report for Applaud Status

Resolved

The incident has been resolved and services are now back to normal
Posted Apr 07, 2026 - 10:47 BST

Update

We are continuing to investigate this issue.
Posted Apr 07, 2026 - 10:47 BST

Update

it's up and running, able to see login page and able to connect to servers
Posted Apr 07, 2026 - 10:46 BST

Update

We are continuing to investigate this issue.
Posted Apr 07, 2026 - 10:45 BST

Update

We’ve escalated the issue to the MongoDB team. The escalation manager has confirmed they are actively working with their internal teams and will provide a resolution as soon as possible. We are closely monitoring and will share updates as we receive them.
Posted Apr 07, 2026 - 10:43 BST

Update

We are working with MongoDB technical support to restore services. It's taking longer than expected to return to normal activity.
Posted Apr 07, 2026 - 10:09 BST

Investigating

fix has been implemented and is going to take another 15 mins or so to recover
Posted Apr 07, 2026 - 09:35 BST
This incident affected: Production EU.